summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2002-02-11 03:10:32 +0000
committerDavid Schleef <ds@schleef.org>2002-02-11 03:10:32 +0000
commit54c46b3d18731526af7b9eac15521827ef3a4a2a (patch)
treee733874e8e3908e2126fb38ab1eb53676a11ac97 /debian
parent432a37d9a89a0f3d9d04cf9bd42102fcbe4e9327 (diff)
mksnapshot: updated version and filenames. control.in: changed
dependency from kernel-headers to kernel-source packages. rules: force HAS_MMU=true, change mipsel to mips, untar kernel-source package include directory and use that as kernel source
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog14
-rw-r--r--debian/control11
-rw-r--r--debian/control.in5
-rwxr-xr-xdebian/mksnapshot10
-rwxr-xr-xdebian/rules20
5 files changed, 44 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index 88396ab32..248f5a0b4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+uclibc (0.9.9-cvs20020210-1) unstable; urgency=low
+
+ * New upstream snapshot.
+ * debian/mksnapshot: updated version and filenames
+ * debian/control.in: changed dependency from kernel-headers to
+ kernel-source.
+ * debian/rules: force HAS_MMU=true
+ * debian/rules: change mipsel to mips
+ * debian/rules: untar kernel-source include directory and use
+ that as kernel source.
+ * Previous 3 lines should fix autobuildability (Closes: #131373)
+
+ -- David Schleef <ds@schleef.org> Sun, 10 Feb 2002 17:11:22 -0800
+
uclibc (0.9.5-cvs20011117-1) unstable; urgency=low
* New upstream snaphot
diff --git a/debian/control b/debian/control
index 63c11451b..18bddbc40 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,13 @@ Source: uclibc
Section: devel
Priority: optional
Maintainer: David Schleef <ds@schleef.org>
-Build-Depends: debhelper, kernel-headers-2.4
+Build-Depends: debhelper, kernel-source-2.4.16
Standards-Version: 3.5.6
Package: libuclibc-dev
Section: devel
-Architecture: i386 powerpc mipsel sh m68k arm
-Depends: libuclibc0 (= ${Source-Version}), ${shlibs:Depends}
+Architecture: arm i386 m68k mips powerpc sh sparc
+Depends: libuclibc0 (= ${Source-Version})
Description: A small implementation of the C library
uClibc is an implementation of the standard C library that is
much smaller than glibc, which makes it useful for embedded
@@ -17,7 +17,8 @@ Description: A small implementation of the C library
Package: libuclibc0
Section: libs
-Architecture: i386 powerpc mipsel sh m68k arm
+Architecture: arm i386 m68k mips powerpc sh sparc
+Depends:
Description: A small implementation of the C library
uClibc is an implementation of the standard C library that is
much smaller than glibc, which makes it useful for embedded
@@ -29,7 +30,7 @@ Description: A small implementation of the C library
Package: uclibc-toolchain
Section: devel
-Architecture: i386 powerpc mipsel sh m68k arm
+Architecture: arm i386 m68k mips powerpc sh sparc
Depends: gcc|c-compiler, binutils, ${shlibs:Depends}
Recommends: libuclibc-dev
Conflicts: uclibc-gcc
diff --git a/debian/control.in b/debian/control.in
index 30f39e2e9..11041432a 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -2,13 +2,13 @@ Source: uclibc
Section: devel
Priority: optional
Maintainer: David Schleef <ds@schleef.org>
-Build-Depends: debhelper, kernel-headers-2.4
+Build-Depends: debhelper, _KERNEL_
Standards-Version: 3.5.6
Package: libuclibc-dev_TARGET_
Section: devel
Architecture: _ARCHS_
-Depends: libuclibc0_TARGET_ (= ${Source-Version}), ${shlibs:Depends}
+Depends: libuclibc0_TARGET_ (= ${Source-Version})
Description: A small implementation of the C library
uClibc is an implementation of the standard C library that is
much smaller than glibc, which makes it useful for embedded
@@ -18,6 +18,7 @@ Description: A small implementation of the C library
Package: libuclibc0_TARGET_
Section: libs
Architecture: _ARCHS_
+Depends:
Description: A small implementation of the C library
uClibc is an implementation of the standard C library that is
much smaller than glibc, which makes it useful for embedded
diff --git a/debian/mksnapshot b/debian/mksnapshot
index b0bbe4beb..6817e59c8 100755
--- a/debian/mksnapshot
+++ b/debian/mksnapshot
@@ -4,6 +4,7 @@
topdir=$(pwd)
today=$(date +%Y%m%d)
version=0.9.9
+dir=uclibc-${version}-cvs${today}
mkdir -p ${topdir}/uclibc-tmp
cd ${topdir}/uclibc-tmp
@@ -14,21 +15,20 @@ then
echo "$CVSROOT" 'Ay=0=a%0bZ' >>~/.cvspass
fi
-cvs co uClibc
+cvs co -D ${dir} uClibc
-cd ${topdir}/uclibc-tmp/uClibc/debian
+cd ${topdir}/uclibc-tmp/${dir}/debian
echo "uclibc (${version}-cvs${today}-1) unstable; urgency=low" >changelog.tmp
echo >>changelog.tmp
echo " * This is an automatic snapshot of uClibc CVS" >>changelog.tmp
echo >>changelog.tmp
echo " -- David Schleef <ds@schleef.org> $(date -R)" >>changelog.tmp
+echo >>changelog.tmp
cat changelog >>changelog.tmp
mv changelog.tmp changelog
cd ${topdir}/uclibc-tmp
-mv uClibc uclibc-${version}-cvs${today}
-tar -czf ../uclibc-${version}-cvs${today}.tgz uclibc-${version}-cvs${today}
-
+tar -czf ../uclibc_${version}-cvs${today}.orig.tar.gz ${dir}
cd ${topdir}
rm -rf uclibc-tmp
diff --git a/debian/rules b/debian/rules
index c20391979..288a211c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,8 @@ major=$(shell grep '^MAJOR_VERSION' Rules.mak|sed 's/.*=//')
minor=$(shell grep '^MINOR_VERSION' Rules.mak|sed 's/.*=//')
version:=$(strip $(major)).$(strip $(minor))
+kernel_source=kernel-source-2.4.16
+
target=$(DEB_HOST_GNU_CPU)
#target=powerpc
@@ -31,14 +33,17 @@ p_gcc=uclibc$(target_suffix)-toolchain
debian/control: debian/control.in debian/rules
sed -e s/_TARGET_/$(target_suffix)/ \
- -e "s/_ARCHS_/i386 powerpc mipsel sh m68k arm/" \
+ -e "s/_ARCHS_/arm i386 m68k mips powerpc sh sparc/" \
+ -e "s/_KERNEL_/$(kernel_source)/" \
debian/control.in >debian/control
build: build-stamp
build-stamp: debian/control
dh_testdir
- # Add here commands to compile the package.
+ # Brute force method of getting kernel headers
+ tar --bzip2 -xf /usr/src/$(kernel_source).tar.bz2 $(kernel_source)/include
+
cp extra/Configs/Config.$(target) Config
echo '#Debian configuration overrides' >>Config
@@ -54,7 +59,8 @@ endif
ifeq ($(with_shared_libs),n)
echo 'HAVE_SHARED = false' >>Config
endif
- echo 'KERNEL_SOURCE = '`echo /usr/src/kernel-headers-*|sed 's/ .*//'` >>Config
+ echo 'KERNEL_SOURCE = '`pwd`/$(kernel_source) >>Config
+ echo 'HAS_MMU = true' >>Config
$(MAKE)
@@ -67,6 +73,8 @@ clean: debian/control
rm -f debian/$(p_dev)
+ rm -rf kernel-source-*
+
# Add here commands to clean up after the build process.
-$(MAKE) clean
@@ -84,7 +92,7 @@ install: build debian/control
# Add here commands to install the package into debian/tmp.
$(MAKE) install_dev PREFIX=`pwd`/debian/$(p_dev)
$(MAKE) install_runtime PREFIX=`pwd`/debian/$(p_lib)
- $(MAKE) install_gcc PREFIX=`pwd`/debian/$(p_gcc)
+ $(MAKE) install_toolchain PREFIX=`pwd`/debian/$(p_gcc)
install -d debian/$(p_gcc)/usr/share/man/man1
install -m 644 debian/uclibc-gcc.1 \
@@ -104,6 +112,10 @@ install: build debian/control
install -m 644 debian/uclibc-readelf.1 \
debian/$(p_lib)/usr/share/man/man1/$(target)-uclibc-readelf.1
+ (cd debian/$(p_dev); find . -name '.*' -exec rm -f '{}' ';')
+ (cd debian/$(p_lib); find . -name '.*' -exec rm -f '{}' ';')
+ (cd debian/$(p_gcc); find . -name '.*' -exec rm -f '{}' ';')
+
ifeq ($(with_shared_libs),y)
ifeq ($(target),$(DEB_HOST_GNU_CPU))
mkdir -p debian/$(p_lib)/lib/