summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2001-07-04 00:18:41 +0000
committerDavid Schleef <ds@schleef.org>2001-07-04 00:18:41 +0000
commit3f9dec7f971a150e4f3509c03245f4a69ce51f22 (patch)
tree3198c8195f6589f30dbe7a639f60dbf98e38fca4 /debian
parent709c1793f5f5153f5b6ef0ca454ab7e2a6769415 (diff)
*** empty log message ***
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control7
-rw-r--r--debian/libuclibc0.postinst6
-rw-r--r--debian/libuclibc0.shlibs10
-rwxr-xr-xdebian/rules51
5 files changed, 20 insertions, 60 deletions
diff --git a/debian/changelog b/debian/changelog
index c93c29977..d57fca025 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,8 @@
-uclibc (0.9.5-cvs20010630-2) unstable; urgency=low
+uclibc (0.9.5-cvs20010702-1) unstable; urgency=low
- * Create cross-compiling packages
+ * Build from CVS
- -- David Schleef <ds@schleef.org> Sat, 30 Jun 2001 17:12:41 -0700
+ -- David Schleef <ds@schleef.org> Mon, 2 Jul 2001 23:16:20 -0700
uclibc (0.9.5-cvs20010630-1) unstable; urgency=low
diff --git a/debian/control b/debian/control
index ae8710161..1463dc494 100644
--- a/debian/control
+++ b/debian/control
@@ -1,11 +1,9 @@
-
Source: uclibc
Section: devel
Priority: optional
Maintainer: David Schleef <ds@schleef.org>
Build-Depends: debhelper
-Standards-Version: 3.0.1
-
+Standards-Version: 3.5.2
Package: libuclibc-dev
Section: devel
@@ -29,10 +27,9 @@ Description: A small implementation of the C library
Package: uclibc-gcc
Section: devel
Architecture: any
-Depends: c-compiler, binutils, ${shlibs:Depends}
+Depends: gcc|c-compiler, binutils, ${shlibs:Depends}
Description: A compiler wrapper for uClibc
This is a small wrapper for gcc, ld, and other toolchain utilities
to do compilation against uClibc instead of the native libc.
This package is used for cross compiling.
-
diff --git a/debian/libuclibc0.postinst b/debian/libuclibc0.postinst
index aac68193e..27a7dfebf 100644
--- a/debian/libuclibc0.postinst
+++ b/debian/libuclibc0.postinst
@@ -1,8 +1,8 @@
#!/bin/sh
-if [ "$1" = "configure" ]; then
- /sbin/ldconfig
-fi
+#if [ "$1" = "configure" ]; then
+# /sbin/ldconfig
+#fi
#DEBHELPER#
diff --git a/debian/libuclibc0.shlibs b/debian/libuclibc0.shlibs
index 5efed49bb..81556def9 100644
--- a/debian/libuclibc0.shlibs
+++ b/debian/libuclibc0.shlibs
@@ -1,6 +1,6 @@
-libuClibc 0 libuclibc0 (>> 0.9.5-0)
-libuClibm 0 libuclibc0 (>> 0.9.5-0)
+libc 0 libuclibc0 (>> 0.9.5-0)
+libm 0 libuclibc0 (>> 0.9.5-0)
ld-uclibc 0 libuclibc0 (>> 0.9.5-0)
-libuClibdl 0 libuclibc0 (>> 0.9.5-0)
-libuClibcrypt 0 libuclibc0 (>> 0.9.5-0)
-libuClibutil 0 libuclibc0 (>> 0.9.5-0)
+libdl 0 libuclibc0 (>> 0.9.5-0)
+libcrypt 0 libuclibc0 (>> 0.9.5-0)
+libutil 0 libuclibc0 (>> 0.9.5-0)
diff --git a/debian/rules b/debian/rules
index 5e3349acb..0a54bf63b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,7 @@ build-stamp:
cp extra/Configs/Config.$(shell echo $(target)|sed 's/i386/x86/') Config
echo '#Debian configuration overrides' >>Config
-ifneq ($(TARGET),native)
+ifneq ($(target),$(DEB_HOST_GNU_CPU))
echo 'TARGET_ARCH = $(target)' >>Config
echo 'CROSS = $(target)-linux-' >>Config
endif
@@ -32,6 +32,9 @@ endif
echo 'PREFIX = $$(DESTDIR)/usr' >>Config
echo 'DEVEL_PREFIX = $$(PREFIX)/$$(TARGET_ARCH)-linux-uclibc' >>Config
echo 'TARGET_PREFIX = $$(DESTDIR)/' >>Config
+ifeq ($(target),powerpc)
+ echo 'HAVE_SHARED = false' >>Config
+endif
$(MAKE)
@@ -55,7 +58,7 @@ install: build
# Add here commands to install the package into debian/tmp.
$(MAKE) install_dev DESTDIR=`pwd`/debian/tmp
- $(MAKE) install_target DESTDIR=`pwd`/debian/libuclibc0
+ $(MAKE) install_runtime DESTDIR=`pwd`/debian/libuclibc0
$(MAKE) install_gcc DESTDIR=`pwd`/debian/uclibc-gcc
install -m 644 debian/uclibc-gcc.1 \
@@ -74,46 +77,6 @@ install: build
install -m 644 debian/uclibc-ldconfig.1 \
debian/libuclibc0/usr/share/man/man1/$(target)-uclibc-ldconfig.1
- # some hacks here
-ifeq ($(TARGET),native)
- (cd debian/libuclibc0/usr/bin;mv ldd $(target)-uclibc-ldd)
- (cd debian/libuclibc0/sbin;mv ldconfig $(target)-uclibc-ldconfig)
-
- (cd debian/tmp/usr/$(target)-linux-uclibc/bin; \
- rm ldd; \
- ln -sf ../../bin/$(target)-uclibc-ldd ldd;)
-
- (cd debian/tmp/usr/$(target)-linux-uclibc/sbin; \
- rm ldconfig; \
- ln -sf /sbin/$(target)-uclibc-ldconfig ldconfig;)
-endif
-
- (cd debian/tmp/usr/$(target)-linux-uclibc/lib; \
- rm ld-uclibc-$(version).so; \
- for x in util c m dl crypt;do \
- rm libuClib$$x-$(version).so; \
- rm lib$$x.so; \
- ln -sf /lib/libuClib$$x-$(version).so lib$$x.so ; \
- rm libuClib$$x.so; \
- ln -sf /lib/libuClib$$x-$(version).so libuClib$$x.so ; \
- done)
-
- (cd debian/tmp/usr/lib; \
- for x in util c m dl crypt;do \
- ln -sf /lib/libuClib$$x-$(version).so libuClib$$x.so ; \
- done)
-
- (cd debian/libuclibc0/lib; \
- for x in util c m dl crypt;do \
- rm lib$$x.so; \
- rm lib$$x.so.0; \
- rm libuClib$$x.so; \
- done)
-
- #(cd debian/tmp/usr/$(target)-linux-uclibc/lib; \
- for x in libutil libc libm libdl libcrypt;do \
- rm $$x.so;done)
-
# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.
@@ -139,13 +102,13 @@ binary-arch: build install
dh_link
dh_strip
dh_compress
- dh_fixperms
+ dh_fixperms -Xld-uclibc
# You may want to make some executables suid here.
# dh_suidregister
# dh_makeshlibs
dh_installdeb
# dh_perl
- dh_shlibdeps --exclude=ld_uclibc -ldebian/libuclibc0/lib
+ dh_shlibdeps --exclude=ld_uclibc -ldebian/libuclibc0/usr/$(target)-linux-uclibc/lib
dh_gencontrol
dh_md5sums
dh_builddeb