summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2001-08-09 01:20:43 +0000
committerDavid Schleef <ds@schleef.org>2001-08-09 01:20:43 +0000
commit0641a78fd4681a4310843bc41ac2b4853baf48df (patch)
tree1639369484f2ec1977312d3600bd9b8bff44ee44 /debian
parentc3bbc0eafdae7a50c46ec61f3352821b7c28ea85 (diff)
Changed uclibc-gcc to uclibc-toolchain. Added fixups for changes
in the Makefiles.
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rw-r--r--debian/control.in4
-rwxr-xr-xdebian/rules7
3 files changed, 13 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 44a74ff53..278bfd6f0 100644
--- a/debian/control
+++ b/debian/control
@@ -23,10 +23,12 @@ Description: A small implementation of the C library
much smaller than glibc, which makes it useful for embedded
systems.
-Package: uclibc-gcc
+Package: uclibc-toolchain
Section: devel
Architecture: any
Depends: gcc|c-compiler, binutils, ${shlibs:Depends}
+Conflicts: uclibc-gcc
+Replaces: uclibc-gcc
Description: A compiler wrapper for uClibc
This is a small wrapper for gcc, ld, and other toolchain utilities
to do compilation against uClibc instead of the native libc.
diff --git a/debian/control.in b/debian/control.in
index 9443af936..1992b0a11 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -23,10 +23,12 @@ Description: A small implementation of the C library
much smaller than glibc, which makes it useful for embedded
systems.
-Package: uclibc_TARGET_-gcc
+Package: uclibc_TARGET_-toolchain
Section: devel
Architecture: any
Depends: gcc|c-compiler, binutils, ${shlibs:Depends}
+Conflicts: uclibc_TARGET_-gcc
+Replaces: uclibc_TARGET_-gcc
Description: A compiler wrapper for uClibc
This is a small wrapper for gcc, ld, and other toolchain utilities
to do compilation against uClibc instead of the native libc.
diff --git a/debian/rules b/debian/rules
index f31438825..3c6603cc3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -104,6 +104,13 @@ ifeq ($(target),$(DEB_HOST_GNU_CPU))
debian/$(p_lib)/lib/ld-uClibc.so.0
endif
endif
+
+ install -d debian/$(p_gcc)/usr/bin
+ mv debian/$(p_gcc)/usr/$(target)-linux-uclibc/bin/$(target)-* \
+ debian/$(p_gcc)/usr/bin
+ install -d debian/$(p_lib)/usr/bin
+ mv debian/$(p_lib)/usr/$(target)-linux-uclibc/bin/$(target)-* \
+ debian/$(p_lib)/usr/bin
# Build architecture-independent files here.
binary-indep: