summaryrefslogtreecommitdiff
path: root/package/curl/patches
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@uclibc-ng.org>2018-04-10 02:55:02 (GMT)
committerWaldemar Brodkorb <wbx@uclibc-ng.org>2018-04-10 02:55:33 (GMT)
commit44af70d2b8349967f884ac86780acf5d2bdb7ea3 (patch)
treef53fe2f2d10634edee3a619ab1675c096e4e4314 /package/curl/patches
parent488353467373dd107976b6d33bc83b6c14397f28 (diff)
curl: update to 7.59.0
Diffstat (limited to 'package/curl/patches')
-rw-r--r--package/curl/patches/patch-lib_vtls_openssl_c52
-rw-r--r--package/curl/patches/patch-src_tool_operate_c6
2 files changed, 55 insertions, 3 deletions
diff --git a/package/curl/patches/patch-lib_vtls_openssl_c b/package/curl/patches/patch-lib_vtls_openssl_c
new file mode 100644
index 0000000..1182df4
--- /dev/null
+++ b/package/curl/patches/patch-lib_vtls_openssl_c
@@ -0,0 +1,52 @@
+--- curl-7.59.0.orig/lib/vtls/openssl.c 2018-03-12 08:18:59.000000000 +0100
++++ curl-7.59.0/lib/vtls/openssl.c 2018-04-10 03:38:32.766247842 +0100
+@@ -104,7 +104,8 @@
+ #endif
+
+ #if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && /* OpenSSL 1.1.0+ */ \
+- !defined(LIBRESSL_VERSION_NUMBER)
++ !(defined(LIBRESSL_VERSION_NUMBER) && \
++ LIBRESSL_VERSION_NUMBER < 0x20700000L)
+ #define SSLEAY_VERSION_NUMBER OPENSSL_VERSION_NUMBER
+ #define HAVE_X509_GET0_EXTENSIONS 1 /* added in 1.1.0 -pre1 */
+ #define HAVE_OPAQUE_EVP_PKEY 1 /* since 1.1.0 -pre3 */
+@@ -128,7 +129,8 @@ static unsigned long OpenSSL_version_num
+ #endif
+
+ #if (OPENSSL_VERSION_NUMBER >= 0x1000200fL) && /* 1.0.2 or later */ \
+- !defined(LIBRESSL_VERSION_NUMBER)
++ !(defined(LIBRESSL_VERSION_NUMBER) && \
++ LIBRESSL_VERSION_NUMBER < 0x20700000L)
+ #define HAVE_X509_GET0_SIGNATURE 1
+ #endif
+
+@@ -147,7 +149,7 @@ static unsigned long OpenSSL_version_num
+ * Whether SSL_CTX_set_keylog_callback is available.
+ * OpenSSL: supported since 1.1.1 https://github.com/openssl/openssl/pull/2287
+ * BoringSSL: supported since d28f59c27bac (committed 2015-11-19)
+- * LibreSSL: unsupported in at least 2.5.1 (explicitly check for it since it
++ * LibreSSL: unsupported in at least 2.7.2 (explicitly check for it since it
+ * lies and pretends to be OpenSSL 2.0.0).
+ */
+ #if (OPENSSL_VERSION_NUMBER >= 0x10101000L && \
+@@ -259,7 +261,9 @@ static void tap_ssl_key(const SSL *ssl,
+ if(!session || !keylog_file_fp)
+ return;
+
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L && \
++ !(defined(LIBRESSL_VERSION_NUMBER) && \
++ LIBRESSL_VERSION_NUMBER < 0x20700000L)
+ /* ssl->s3 is not checked in openssl 1.1.0-pre6, but let's assume that
+ * we have a valid SSL context if we have a non-NULL session. */
+ SSL_get_client_random(ssl, client_random, SSL3_RANDOM_SIZE);
+@@ -2082,8 +2086,7 @@ static CURLcode ossl_connect_step1(struc
+ case CURL_SSLVERSION_TLSv1_2:
+ case CURL_SSLVERSION_TLSv1_3:
+ /* it will be handled later with the context options */
+-#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && \
+- !defined(LIBRESSL_VERSION_NUMBER)
++#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
+ req_method = TLS_client_method();
+ #else
+ req_method = SSLv23_client_method();
diff --git a/package/curl/patches/patch-src_tool_operate_c b/package/curl/patches/patch-src_tool_operate_c
index f9b563b..d26db35 100644
--- a/package/curl/patches/patch-src_tool_operate_c
+++ b/package/curl/patches/patch-src_tool_operate_c
@@ -1,6 +1,6 @@
---- curl-7.42.0.orig/src/tool_operate.c 2015-04-16 23:39:50.000000000 +0200
-+++ curl-7.42.0/src/tool_operate.c 2015-04-24 13:31:09.000000000 +0200
-@@ -1828,8 +1828,10 @@ CURLcode operate(struct GlobalConfig *co
+--- curl-7.59.0.orig/src/tool_operate.c 2018-03-12 08:18:59.000000000 +0100
++++ curl-7.59.0/src/tool_operate.c 2018-04-04 21:25:59.972439422 +0100
+@@ -1947,8 +1947,10 @@ CURLcode operate(struct GlobalConfig *co
if(res == PARAM_HELP_REQUESTED)
tool_help();
/* Check if we were asked for the manual */