From f0446fcb9cc4afdb7a0f11263815e04699c12346 Mon Sep 17 00:00:00 2001
From: David Schleef <ds@schleef.org>
Date: Sat, 11 Aug 2001 03:19:52 +0000
Subject: Change name of package to uclibc-toolchain.  Various changes
 following the Makefile changes.

---
 debian/rules | 24 ++++++++++--------------
 1 file changed, 10 insertions(+), 14 deletions(-)

(limited to 'debian')

diff --git a/debian/rules b/debian/rules
index 3c6603cc3..1922cfab0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,7 +27,7 @@ endif
 
 p_dev=libuclibc-dev$(target_suffix)
 p_lib=libuclibc0$(target_suffix)
-p_gcc=uclibc$(target_suffix)-gcc
+p_gcc=uclibc$(target_suffix)-toolchain
 
 debian/control: debian/control.in debian/rules
 	sed s/_TARGET_/$(target_suffix)/ debian/control.in >debian/control
@@ -45,9 +45,10 @@ ifneq ($(target),$(DEB_HOST_GNU_CPU))
 	echo 'CROSS = $(target)-linux-'  >>Config
 endif
 	echo 'DOPIC = true'  >>Config
-	echo 'PREFIX = /usr'  >>Config
-	echo 'DEVEL_PREFIX = $$(PREFIX)/$$(TARGET_ARCH)-linux-uclibc'  >>Config
-	echo 'TARGET_PREFIX = /'  >>Config
+	echo 'SYSTEM_DEVEL_PREFIX = /'  >>Config
+	echo 'DEVEL_PREFIX = /usr/$$(TARGET_ARCH)-linux-uclibc'  >>Config
+	echo 'SHARED_LIB_LOADER_PATH = /lib'  >>Config
+	#echo 'TARGET_PREFIX = /'  >>Config
 ifeq ($(with_shared_libs),n)
 	echo 'HAVE_SHARED = false' >>Config
 endif
@@ -62,6 +63,8 @@ clean: debian/control
 	dh_testroot
 	rm -f build-stamp
 
+	rm -f debian/$(p_dev)
+
 	# Add here commands to clean up after the build process.
 	-$(MAKE) clean
 
@@ -77,9 +80,9 @@ install: build debian/control
 	ln -s tmp debian/$(p_dev)
 
 	# Add here commands to install the package into debian/tmp.
-	$(MAKE) install_dev DESTDIR=`pwd`/debian/$(p_dev)
-	$(MAKE) install_runtime DESTDIR=`pwd`/debian/$(p_lib)
-	$(MAKE) install_gcc DESTDIR=`pwd`/debian/$(p_gcc)
+	$(MAKE) install_dev PREFIX=`pwd`/debian/$(p_dev)
+	$(MAKE) install_runtime PREFIX=`pwd`/debian/$(p_lib)
+	$(MAKE) install_gcc PREFIX=`pwd`/debian/$(p_gcc)
 
 	install -d debian/$(p_gcc)/usr/share/man/man1
 	install -m 644 debian/uclibc-gcc.1 \
@@ -104,13 +107,6 @@ ifeq ($(target),$(DEB_HOST_GNU_CPU))
 	  debian/$(p_lib)/lib/ld-uClibc.so.0
 endif
 endif
-	
-	install -d debian/$(p_gcc)/usr/bin
-	mv debian/$(p_gcc)/usr/$(target)-linux-uclibc/bin/$(target)-* \
-		debian/$(p_gcc)/usr/bin
-	install -d debian/$(p_lib)/usr/bin
-	mv debian/$(p_lib)/usr/$(target)-linux-uclibc/bin/$(target)-* \
-		debian/$(p_lib)/usr/bin
 
 # Build architecture-independent files here.
 binary-indep:
-- 
cgit v1.2.3